Response time

Major incident Website
3 hours, 56 minutes

Updates

Resolved

Problem is solved. Response time improved. Database operations restored to normal.

March 18, 2020 · 00:24 CEST
Issue

We’re currently expieriencing long runtimes on database request on our main website. Due to this you may experience website responding slowly or not responding at all. The issue is identified and we’re working on a solution.

March 17, 2020 · 23:30 CEST