SMTP service is down on Mailserver

Major incident Mail
1 minute

Updates

Resolved

Automatic Notification.

Problem has been resolved.

March 19, 2020 · 14:17 CEST
Issue

Automatic notification.

An administrator will review this issue as soon as possible.

Problem name: SMTP service is down on Mailserver

March 19, 2020 · 14:16 CEST