SMTP service is down on Mailserver

Major incident Mail
2 minutes, 1 second

Updates

Resolved

Automatic Notification.

Problem has been resolved.

March 22, 2020 · 20:23 CEST
Issue

Automatic notification.

An administrator will review this issue as soon as possible.

Problem name: SMTP service is down on Mailserver

March 22, 2020 · 20:21 CEST

← Back