TeamSpeak 3 - Query is down

Major incident Teamspeak3
1 minute

Updates

Resolved

Automatic Notification.

Problem has been resolved.

April 9, 2020 · 09:34 CEST
Issue

Automatic notification.

An administrator will review this issue as soon as possible.

Problem name: TeamSpeak 3 - Query is down

April 9, 2020 · 09:33 CEST