TeamSpeak 3 - Query is down

Major incident Teamspeak3
7 minutes

Updates

Resolved

Automatic Notification.

Problem has been resolved.

April 13, 2020 · 11:23 CEST
Issue

Automatic notification.

An administrator will review this issue as soon as possible.

Problem name: TeamSpeak 3 - Query is down

April 13, 2020 · 11:16 CEST

← Back