IMAP service is down on Mailserver

Major incident Mail
3 hours, 19 minutes, 1 second

Updates

Resolved

Automatic Notification.

Problem has been resolved.

April 13, 2020 · 16:28 CEST
Issue

Automatic notification.

An administrator will review this issue as soon as possible.

Problem name: IMAP service is down on Mailserver

April 13, 2020 · 13:09 CEST