SMTP service is down on Mailserver

Major incident Mail
12 minutes, 59 seconds

Updates

Resolved

Automatic Notification.

Problem has been resolved.

April 13, 2020 · 13:22 CEST
Issue

Automatic notification.

An administrator will review this issue as soon as possible.

Problem name: SMTP service is down on Mailserver

April 13, 2020 · 13:09 CEST

← Back