SMTP service is down on Mailserver

Major incident Mail
2 hours, 1 minute

Updates

Resolved

Automatic Notification.

Problem has been resolved.

April 13, 2020 · 16:30 CEST
Issue

Automatic notification.

An administrator will review this issue as soon as possible.

Problem name: SMTP service is down on Mailserver

April 13, 2020 · 14:29 CEST